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1. Introduction 
BadgeMaker has been implemented successfully in thousands of organizations worldwide to 
issue national ID’s, driver licenses, passports, civil identification and social security cards. 
Use the full power and advanced features with BadgeMaker such as biometrics, contact and 
contactless smart cards. 

 
With BadgeMaker Lite an MSAccess demo database is included that illustrates most features 
in the software. You can use the demo database as a reference when you create your own 
BadgeMaker project or you can test different features you would like to integrate in your 
own project. 
 
IMPORTANT: Badgemaker Lite offers a limited number of records (100) and is also limited to 
(1) project. If you want to use more records and create additional projects, please contact 
your software supplier to upgrade your Badgemaker Lite to Badgemaker Basic. 
 
This document is meant as a guide to installing your software and initial system set up, it 
describes the process of defining a database, creating a card design and producing finished 
cards. This document is intended as a quick start guide only, for a detailed description of 
the software and its advanced features please consult the Help Files in BadgeMaker. 

2. Installation 

2.1 Installing ScreenCheck Software 

For installation of BadgeMaker Software please follow these simple steps: 
 
• Insert the ScreenCheck BadgeMaker CD into the CD-ROM, the CD will automatically 

launch setup. 
• From the Main Menu select “Install BadgeMaker”. 
• From the Welcome Setup Screen select “Next” to begin installation. Follow the install 

process step by step (ScreenCheck advises to accept all default options).  
 
You must register the software to obtain a license key for full functionality. Follow 
instructions when prompted after the installation has completed. 
 
Make sure you have administrator rights when you install on a Windows Vista or Windows XP 
workstation. 

2.2 Uninstalling ScreenCheck Software 

BadgeMaker can be uninstalled by selecting it in “Add or Remove Programs” from the 
Control Panel. 

2.3 Installing ScreenCheck Hardware 

Please be sure to install hardware components to begin producing ID cards (camera, and 
printers). 
 
ScreenCheck offers a wide range of products to use with BadgeMaker to suit our customer’s 
needs. Help files and manuals are available describing in detail the installation and setup of 
these products. If you encounter problems please contact our Support Department. 
support@screencheck.com  

mailto:support@screencheck.com�
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2.4 Installing the card printer 

To install a printer please follow the instructions in the documentation supplied with the 
printer. If you encounter problems please contact our Support Department. 
support@screencheck.com  

2.5 Installing the camera 

A wide range of camera models can be used to meet the requirements and budget suiting 
the needs of our customers. Help documents and manuals are available to aid in the 
installation and configuration of these cameras. If you encounter problems please contact 
our Support Department. support@screencheck.com  

3. Getting Started 

The BadgeMaker software consists of two components integrated into one application. Each 
component with its own functionality. 

3.1.1 Badge Creator (BC): This module is used to create badge layouts with 
dynamic/static text, logos, signatures, photos, and magstripe information. 

3.1.2 Badge Maker (BM): This module is used to create a database and enter data into the 
database, acquire images and print cards. This module is the main screen of BadgeMaker. 

With BadgeMaker an MSAccess demo database “DEMOLITE.BM” is included. It contains a 
ready to use database and card layout showing the software’s capabilities. You may use this 
as a reference to create your own BadgeMaker project or use it to test various features you 
would like to include in your project. 

3.2 Launching BadgeMaker 

Select “BadgeMaker” located in the “Programs” folder in the “Start Menu”. BadgeMaker 
will open for the first time. 

4. Activate BadgeMaker 
When BadgeMaker is installed for the first time you must register the software in order to 
gain full functionality. A Software Activation Code (SAC) is shipped with BadgeMaker. With 
this Software Activation Code you can register BadgeMaker on the internet. After 
registering, a registration name and key is sent to you by email automatically. 

 
In trial mode, a message is shown every time BadgeMaker is started. 
 

 
 
Select yes to open the registration window. 
 

mailto:support@screencheck.com�
mailto:support@screencheck.com�
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Select the Help Menu and then click About. 
 
The following dialog box is presented. 
 

 
 
Now click Enter key and the Enter Key window will appear.  
 

 
 
You must obtain a Name and Key to activate BadgeMaker.  
 
Follow the instructions on the screen. 
 
Click on the link and the website (http://register.screencheck.comto register.  
 

http://www.register.screencheck.com/�
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The hardware-fingerprint is already filled in. You must enter the SAC that came when you 
purchased BadgeMaker. Enter the Software Activation Code you received in the field and all 
other fields marked with * are mandatory.  
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Remember “Registration Name/Company”, this is needed for the registration along with 
the key. When you have entered all required information, click the Submit Information 
button and you will receive an e-mail with your Registration details including a key. 
 
If you do not have internet access on the PC where BadgeMaker is installed, you can register 
on another machine but you must remember the Hardware-Fingerprint from the original 
computer/server BadgeMaker is to be installed on and fill this in on the website manually. If 
you enter an incorrect Hardware-Fingerprint registration will fail and use of BadgeMaker will 
remain restricted. 

5. Creating badge layouts in Badge Creator (BC) 
In the previous chapter we created a project *.BM file with the necessary settings for 
BadgeMaker. This chapter will look at designing badge layouts  
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5.1 Badge Creator Wizard 

Select “New badge” from the “File” menu in BadgeMaker to start the BC component. The 
“Layout wizard” will begin. 

 

Select “Next” to continue. 
 

5.1.1 Step 1 – Layout Type 

Select the type of layout to create. Select “Badge” to design a card layout. Do not tick the 
“Use Template” option. If you select “Use Template” you are restricted to existing 
template designs. Select “Next”. 

5.1.2 Step 2 – Badge Type 

Select a name for the new card design. Leave the default type value of “ISO-Card 86/54.5”. 
Select portrait or landscape to design in. Select “Next”. 

5.1.3 Step 3 – Badge Layout 

This step is solely to specify a background colour to your card design. Select “Next”. 

5.1.4 Step 4 – Badge Fields 

Select the fields you want to include into your badge design. Select “Next”. 

5.1.5 Step 5 – Badge Options 

These options are indicative only and can be ignored in most instances. 

5.1.6 Step 6 – Finished 

Select “Finish” to complete and exit the wizard. 

You will now see a blank badge layout. You can zoom in or out of the layout by clicking on 
the “Zoom In” or “Zoom Out” buttons in the toolbar. 
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5.2 Add items to the layout 

By selecting Edit>Add Item from the menu, the following options can be found: 

5.2.1 Static Text 

Select “Static Text“to add static text to the badge layout. 
After selecting this option you see the following dialog box: 

 

Data tab  

Type your fixed data into the text box. At the bottom of the dialog in the preview window 
this text will be displayed with the selected font, style and colour. Use the ‘Word wrap’ 
option if the text you entered is too long for one line. 

Position tab 

In most cases this can skipped as it is easier using a mouse to drag & drop and resize the 
text after it has been added to the card layout. 

Font tab 

Select the text font, style, size and colour of the text. Alignment and some effects can also 
be set. 

5.2.2 Dynamic Text 

Select “Dynamic Text” to add dynamic text to the badge layout. Dynamic text is 
information added from a database field previously defined in the PROJECT. After selecting 
this option you see the following dialog box: 
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The “Position” and “Font” tabs are identical to those described in Section 5.2.1. 
 
Data tab 
 
Select “Field” to obtain a list of available fields. 
 

 
 
Select a field and click ‘OK’ to confirm. 
 
You can also type a string that can be built of one or more database fields in combination 
with constants. With the space button a +” “+ will be added to the string. Now another 
database filed or constant can be added to the string. In this example Field “Firstname” – 
Space - Field “Surname” are entered: 
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5.2.3 Add Logo 

Select “Add Logo“to add a logo to the badge layout.  

The logo file must be in *.jpg or *.bmp format. 

It is strongly recommended that any logos are stored in the logo folder of the project 
directory, C:\SC\BMLite\PROJECTS\project_name\LOGOS. 
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Select the logo to be added and click “Open”. To edit the logo properties simply double 
click the logo once added to the design. If your logo has a black or white background use 
the “Transparent” option to make the logo transparent. 

5.2.4 Add Dynamic Logo 

Use this option to select “Add Dynamic logo” to your badge layout. 

5.2.5 Add Image Item 

Select “Add Image” to add an image to your badge layout.  

Select one of the available image types (photo, signature, etc.) to add to the layout. 

 

5.2.6 Barcode   

Use this option to add a barcode that is dependent on the contents of one or more database 
fields to your badge layout. Select the “Add Barcode” to display the dialogue box. 

5.3 Shapes 

You can add shapes by selecting the following “Add Line”, “Add Rectangle”, “Add Circle”. 
All three when selected result in the same dialogue box. 
 
Position tab 
Use the “Position tab” to position and define the dimensions. 
 
Colour tab 
Use the “Color tab” to define the colour of the shape, line thickness and fill options. 

6. Editing 

When items are added to your badge layout, you can edit their properties. 
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6.1 Save 

Use this command to save changes made to the current badge layout. 

6.2 Save as 

Use this command to save the current badge layout as another filename. 

6.3 Delete Item 

Select an item from the layout and hit the delete button on your keyboard. 

6.4 Editing existing items 

Click on an item to select it and then select Item from the “Edit” menu or double click on 
an item. The dialogue will look the same as when a new item is added. You can make the 
necessary changes. 

6.5 Snap to reference line 

In the “Options” menu a reference line can be set. Depending on the settings (left 
alignment, center alignment, right alignment etc.), items will be aligned to the reference 
line by right-clicking on the item and selecting “Snap to reference line” option. 

6.6 Badge Layout  

Use this option from the “Edit menu” to adjust the layout settings of the currently opened 
layout. The “Edit Badge Layout” dialogue is similar to the “New Badge Layout” dialogue.  

6.7 Open Layout 

Existing badge layouts can be seen in the “Project Explorer” window located on the right 
hand side of the screen. From here you can open an existing badge layout by double-clicking 
on the badge name. 

6.8 Remove Layout 

Existing badge layouts can be removed from the project by right-clicking the layout listed in 
“Project Explorer” and selecting “Remove from Project” 

6.9 Help  

Press the F1 button or select “Help Index” from the “Help” menu to open the BadgeCreator 
help files. Help can be found based on a category in the menu or on a keyword.  

7. Encode options 

7.1 Magnetic layout mode 

Use this mode to add magnetic encoding data to your badge layout. 
 
 
Once you have completed creating a new project and created your badge layouts in BC. You 
are now ready to produce your cards by returning to the main Badge Maker screen (BM). 
Select “Back to main Screen” on the toolbar. 
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8. BadgeMaker (BM) 
Now that you have created a project and produced badge layouts you are ready to use 
BadgeMaker (BM). BadgeMaker is the main screen where data is entered, images are 
acquired and finally cards are printed. 

8.1 Default project 

BadgeMaker Lite will open into a ready built database which you can edit or use to test the 
functionalities. 
 
The project will open displaying all data entered to date. 

 
 

8.2 Adding, editing and deleting records 

8.2.1 Add Record 

Records can be added to the project by selecting the “+” button on the toolbar or by 
selecting Record>Add option from the menu. 
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 The add record option can be disabled by the administrator. 

8.2.2 Delete Record 

To “Delete” an existing record you must “tag” the record first. Tick the box next to the 
record so it becomes “tagged”. Once the record is tagged select Record>Delete or simply 
press delete on your keyboard. 

 

 
 

8.2.3 Edit Record 

To “Edit” a record simply double-click in any of the fields associated with that record or by 
selecting Record>Edit. This time you will see the fields are filled with information. You are 
now in edit mode, read only fields will be marked gray. 
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8.3 Acquiring images 

When data has been entered and a record is created, an image can be acquired and bound 
to that record. You will need a capturing device for photo capture. Most of these devices 
can be controlled with a TWAIN driver or a direct device driver. To acquire an image first 
define a source by selecting Image>Select source. Here the driver can be selected for your 
capture device. Select the driver belonging to your device from the drop down list or select 
“TWAIN” which displays a list of “Direct” device drivers. 
 

 
 

TWAIN drivers are generally included with scanners, digital cameras and image capture 
boards. 

 
Select the correct driver for your device from the available list and click “OK”. 

8.4 Acquire an image 

To acquire an image select Image>Acquire from the menu or right click inside the “Photo” 
dialogue box and select “Acquire”. 
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The device driver should load and launch a window with a live image from the camera. 
Position the subject within the image frame and select “Freeze” to take a snapshot (shown 
below). 
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Next you must crop the image as required and accept “Transfer”. The photo is now added 
to your database and bound to a record. 

9. Printing records 

When the project has been populated and the records are complete they can now be printed 
using the badge layout previously created in Badge Creator. Select the record to be printed.  

 
To check the result in advance before you print your ID card you can use “Print preview” 
select File>Print Preview. The current record is displayed as it will be printed out.  
 
To print one or more cards select File>Print from the menu or select the “Print” button on 
the toolbar. The following dialogue box is displayed. 

 
 
Check the correct printer is selected. You can change the properties of the printer driver by 
clicking on “Properties”. 
 

9.1 Printing multiple records 

Multiple records can be selected for batch printing by tagging multiple records and selecting 
print. 
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You also have the option to “Select All”. The Record>Tag all option selects all records held 
in the database. 

The records are now ready to be printed and card production can start! 

To exit the application select File>Exit from the menu or click on the standard Windows 
exit button in the top-right corner. 
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